Tentacle sync setup app android 6.0

3.04K viewsSoftware

Dear Tentacle,

I ‘ve just seen that my Android 6.0 devices can’t run the app tentacle setup.

It says that is not compatible

I don’t know how it is possibile since it requires android 5.0 or upper version and I have 6.0 android

 

please let me know